Brigole forum

Forum consacré au bricolage en général et à la détente !
 
AccueilFAQRechercherS'enregistrerConnexion
Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Derniers sujets
» caméra déportée sur chien
par amosjerome Ven 17 Nov - 11:02

» arduino self balancing project
par amosjerome Dim 3 Sep - 22:52

» Table de tir 20 lignes
par bricoleur_1 Mar 22 Aoû - 19:37

» roue à aubes
par qtth Sam 20 Mai - 23:45

» Simulation acoustique
par Biduleohm Mar 24 Jan - 15:14

» DAC en réseau R-2R pour appli à faible résolution
par Biduleohm Mar 10 Jan - 23:38

» Corps de chauffe
par Antot Sam 31 Déc - 0:41

» Anémomètre[RESOLU]
par Biduleohm Jeu 22 Déc - 15:30

» Électrocardiogramme détection mouvement
par amosjerome Sam 3 Déc - 2:16

Partenaires
Mots-clés
hilarant couteau mousse elastique voiture

Partagez | 
 

 Anémomètre[RESOLU]

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
bricoleur_1
Mac'Gyver
Mac'Gyver
avatar

Masculin Nombre de messages : 1054
Age : 20
Localisation : Sotteville-lès-Rouen
Emploi/loisirs : Électronique-Électricité-Informatique-Pyrotechnie-Bricolage-Spectacles
Humeur : Biseptine est votre ami! ;)
Date d'inscription : 27/11/2011

MessageSujet: Anémomètre[RESOLU]   Dim 18 Déc - 19:33

Bonjour à toutes et à tous,

J'ai soudé et donc réalisé un circuit que j'avais conçu avec vous à propos d'un anémomètre. Le voici : http://hpics.li/0dc94b3 ( je sais, il y a beaucoup mieux mais j'aimerais VRAIMENT débogger celui-ci svp .. )

Lorsque ma carte relai n'est pas branchée, le circuit fonctionne ( évidemment le relai ne claque pas puisqu'il y en a plus mais lors de la rotation d'une certaine vitesse de l'anémomètre, la del clignote convenablement ).

Cependant, lorsque je branche ma carte relai, cela ne fonctionne plus DU TOUT.

J'ai donc remplacé la carte relai par une del que j'ai mis entre Vcc et le collecteur du 2n2222A et sans même tourner l'anémomètre, les deux dels ( celle de remplaçement et celle qui doit clignoter de base) se mettent à clignoter très très rapidement...

Je suis donc dans une impasse avec ce circuit qui en plus est fini de souder... Si une âme bienfaisante pouvait m'aider à débogger ce circuit ou me mettre sur une piste, ce serait très gentil.

Merci à tous,

Edit : Après avoir branché une tension supérieure ( 4.5v ), la del reste allumée mais clignote quand y a du vent, cependant, le relai claque dès la mise sous tension...Donc voici un autre pb ...


Dernière édition par bricoleur_1 le Lun 19 Déc - 19:04, édité 1 fois
Revenir en haut Aller en bas
Biduleohm
Modérateur
Modérateur
avatar

Masculin Nombre de messages : 8851
Age : 26
Localisation : 77 Seine-et-Marne
Emploi/loisirs : bricolage, informatique, électronique, THT, laser, aquariophilie
Humeur :  
Date d'inscription : 25/03/2009

MessageSujet: Re: Anémomètre[RESOLU]   Lun 19 Déc - 15:46

L'image passe pas (FW du boulot ?)

Si l'image est un schéma tu peux la ré-uploader sur un autre hébergeur stp ?

Si l'image n'est pas un schéma tu peux uploader le schéma du circuit stp ?

_________________
Mes créations  Mon site  Mon forum  Congratulations !!! You've just created a temporal loophole...
Revenir en haut Aller en bas
http://biduleohm.free.fr/
bricoleur_1
Mac'Gyver
Mac'Gyver
avatar

Masculin Nombre de messages : 1054
Age : 20
Localisation : Sotteville-lès-Rouen
Emploi/loisirs : Électronique-Électricité-Informatique-Pyrotechnie-Bricolage-Spectacles
Humeur : Biseptine est votre ami! ;)
Date d'inscription : 27/11/2011

MessageSujet: Re: Anémomètre[RESOLU]   Lun 19 Déc - 18:19

Bonjour, merci mais du coup probleme résolu. Voici comment j'ai fait :

Pour le seuil, j'ai rajouté deux leds pour augmenter le seuil de 1.2v, il faut donc une rotation plus rapide pour que tout s'actionne ( et après test on sent la différence quand meme, et vu a la vitesse à laquelle ca doit tourner ca doit pas etre loin des trente kms/h ( vu la vitesse de la perceuse qui a fait tourner l'axe ( une avec variateur pour que ce soit réaliste biensur..))).

Pour la réparation j'ai mis une résistance entre le GND et la fonction R3/R5, pour mettre à 0 lorsque pas de jus du géné.

Résultat : LED éteinte si géné immobile, LED clignotante si seuil dépassé, et claquement de ma carte relai si la del clignote donc si le seuil est dépassé.

Enfin, comme le relai avait tendance, à une certaine plage de tension, à osciller, j'ai rajouté un condensateur 22µF sur son entrée, comme ça plus d'oscillations ! Le circuit tourne impecc' comme je le voulais !

Pour le schema, on peut le retrouver en #1 de ce forum : https://www.abcelectronique.com/forum/showthread.php?p=850210#post850210
Revenir en haut Aller en bas
Biduleohm
Modérateur
Modérateur
avatar

Masculin Nombre de messages : 8851
Age : 26
Localisation : 77 Seine-et-Marne
Emploi/loisirs : bricolage, informatique, électronique, THT, laser, aquariophilie
Humeur :  
Date d'inscription : 25/03/2009

MessageSujet: Re: Anémomètre[RESOLU]   Mar 20 Déc - 14:52

Ah oui, il manquait une résistance pour décharger le condo. Augmente la valeur de cette résistance et/ou augmente C1 si tu veux éviter que le bazar oscille trop.

Ceci dit c'est un peu (beaucoup) moche comme solution Razz, le mieux (et ironiquement presque plus simple) aurait été d'utiliser un comparateur avec un peu d'hystérésis pour éviter toute oscillation Wink

_________________
Mes créations  Mon site  Mon forum  Congratulations !!! You've just created a temporal loophole...
Revenir en haut Aller en bas
http://biduleohm.free.fr/
bricoleur_1
Mac'Gyver
Mac'Gyver
avatar

Masculin Nombre de messages : 1054
Age : 20
Localisation : Sotteville-lès-Rouen
Emploi/loisirs : Électronique-Électricité-Informatique-Pyrotechnie-Bricolage-Spectacles
Humeur : Biseptine est votre ami! ;)
Date d'inscription : 27/11/2011

MessageSujet: Re: Anémomètre[RESOLU]   Mar 20 Déc - 23:45

Effectivement c'est celle-ci qu'il manquait.

Oui oui mais ma contrainte était d'utiliser que ce que j'avais comme matériel et par conséquent je n'avais que ça mais oui un comparateur c'est parfait. Pour les oscillations j'ai mis un 22µF sur l'entrée du relai ça l'a calmé Smile

Sinon, en DUT GEII où je suis on parle d'hystérésis, mais avec des AOP, dans le cas de comparateur à double seuil mais je n'ai absolument rien compris et non plus avec internet, peux tu m'expliquer brièvement à quoi correspond l'hystérésis stp ?
Revenir en haut Aller en bas
Biduleohm
Modérateur
Modérateur
avatar

Masculin Nombre de messages : 8851
Age : 26
Localisation : 77 Seine-et-Marne
Emploi/loisirs : bricolage, informatique, électronique, THT, laser, aquariophilie
Humeur :  
Date d'inscription : 25/03/2009

MessageSujet: Re: Anémomètre[RESOLU]   Mer 21 Déc - 2:33

Sauf que le problème c'est que le reste continue d'osciller et un montage qui oscille c'est jamais bon (sauf si c'est un oscillateur...).

En gros il y a deux seuils au lieu d'un. Par ex au lieu que la sortie bascule de off à on quand l'entrée dépasse 5 V et bascule de on à off quand elle repasse sous les 5 V, il faut qu'elle dépasse 6 V pour que la sortie bascule de off à on puis qu'elle passe sous 4 V pour qu'elle bascule de on à off.

La différence entre 6 et 4 V (soit 2 V) est appelée hystérésis et permet d'éviter que la sortie bascule constamment si l'entrée est proche d'un seuil unique (genre elle varie rapidement entre 4.95 V et 5.05 V alors que toi tu cherches à surtout à surveiller des variations lentes entre 1 et 10 V par ex), notamment à cause du bruit (aucun signal n'est parfait et même si l'entrée est à pile 5 V en réalité elle varie constamment un tout petit peu et ça suffit à faire basculer le comparateur si y'a pas d'hystérésis).

Une solution un peu foireuse (mais toujours mieux que rien) sur un montage sans hystérésis est de faire un filtre passe-bas sur l'entrée ce qui va éliminer le bruit de la mesure, mais pas le bruit intrinsèque au montage (donc le comparateur peut quand même osciller).

_________________
Mes créations  Mon site  Mon forum  Congratulations !!! You've just created a temporal loophole...
Revenir en haut Aller en bas
http://biduleohm.free.fr/
bricoleur_1
Mac'Gyver
Mac'Gyver
avatar

Masculin Nombre de messages : 1054
Age : 20
Localisation : Sotteville-lès-Rouen
Emploi/loisirs : Électronique-Électricité-Informatique-Pyrotechnie-Bricolage-Spectacles
Humeur : Biseptine est votre ami! ;)
Date d'inscription : 27/11/2011

MessageSujet: Re: Anémomètre[RESOLU]   Mer 21 Déc - 19:20

Revenir en haut Aller en bas
Biduleohm
Modérateur
Modérateur
avatar

Masculin Nombre de messages : 8851
Age : 26
Localisation : 77 Seine-et-Marne
Emploi/loisirs : bricolage, informatique, électronique, THT, laser, aquariophilie
Humeur :  
Date d'inscription : 25/03/2009

MessageSujet: Re: Anémomètre[RESOLU]   Jeu 22 Déc - 15:30

C'est la description mathématique de ce que j'ai dit, sauf que c'est pour une porte inverseuse, là la courbe correspondante à mon poste ressemble plutôt à celle-ci: https://1.bp.blogspot.com/-hKI0vNojHrM/Vo124Q0usiI/AAAAAAAABSE/zvcKjsZK9kc/s1600/chronogramme%2Btrigger%2Bde%2BSchmitt%2Binverseur.png avec E la tension de l'entrée, S la tension de la sortie, VT+ le seuil haut (6 V dans mon exemple) et VT- le seuil bas (4 V dans mon exemple) qui est équivalente à celle-ci: https://upload.wikimedia.org/wikipedia/commons/thumb/a/aa/Hysteresis_sharp_curve.svg/200px-Hysteresis_sharp_curve.svg.png si on exprime S en fonction de E.

Plus d'infos: https://fr.wikipedia.org/wiki/Bascule_de_Schmitt

_________________
Mes créations  Mon site  Mon forum  Congratulations !!! You've just created a temporal loophole...
Revenir en haut Aller en bas
http://biduleohm.free.fr/
Contenu sponsorisé




MessageSujet: Re: Anémomètre[RESOLU]   

Revenir en haut Aller en bas
 
Anémomètre[RESOLU]
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [RESOLU] Fichier MP3 PHOTO VIDEO Supprimer de ma SDcard
» [RESOLU] Flash rom officliel
» [RESOLU] Icone du menu demarrer / raccourci
» [RESOLU] wi-fi et android
» [RESOLU] IE ne bascule pas

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Brigole forum :: Divers :: Discussions générales-
Sauter vers: